Possible problème forum

Un souci ? Une question ? Une suggestion pour le site ou le forum ?

Modérateurs: Rédacteurs, Programmeurs, Modérateurs

Retourner vers Fonctionnement



Possible problème forum

Messagepar Kim Nielsen » 30 Mar 2023, 12:39

Bonjour !
J'ai un soucis avec le forum, aujourd'hui, avec les copier coller, ou le nombre de carractères.
Je m'explique :
D'habitude, pour faire mes avants match, je prépare tout dans word, puis je copie/colle dans le forum et ça roule.
Quand j'ai commencé mes tests, ce matin, ça fonctionnait normalement, jusqu'à ce que... plus rien.
Mon texte collé se voit dans le champ de réponse et quand je clique sur "aperçu", ce mal poli me sort : "Votre message ne contient aucun caractère." et la page est vide.
J'ai essayé d'écrire directement quelques caractères, là ça marche.
J'ai essayé de copier/coller quelques lignes de ma présentation, ça marche.
J'ai essayé de coller quelques autres lignes après les précédentes, ça marche pas.
J'ai testé 3 navigateurs différents (Firefox, Chrome et Edge), pareil pour tous.
J'ai essayé sur un autre forum phpbb, ça marche.
Il n'y a qu'ici que ça foire.
Bien entendu j'ai relancé mes logiciels et j'ai redémarré mon pc. Aucun changement.
On dirait qu'à partir d'un certain nombre de caractères, ça efface tout, alors qu'1/4h avant, c'était bon.
Une idée ?

Edith : pour être exhaustif, j'ai aussi changé de système d'exploitation, (dual boot) en passant sur Xubuntu, et le problème est le même.

Je vais voir si ça ne peut pas être un problème dans le fichier que je copie/colle.
Avatar de l’utilisateur
Kim Nielsen
Rédacteur
Rédacteur
 
Messages: 9314
Enregistré le: 23 Mai 2003, 19:13
Localisation: St Martin de Crau

Re: Possible problème forum

Messagepar peezee » 30 Mar 2023, 12:59

Kim Nielsen, j'ai déjà eu un problème similaire, ça peut arriver lorsqu'un caractère "spécial" (mais parfois invisible genre escape char ou autre) est inséré dans le texte. Et comme le texte en question vient de Word, tout est possible en matière de caractères spécieux spéciaux. :mrgreen:

Je te suggère deux trucs :

1- copie/colle depuis Word d'abord dans un éditeur de texte "normal", genre Notepad++ (qui doit d'ailleurs permettre de visualiser tous les caractères dans le texte) voire mm dans Notepad, ensuite tu c/c depuis cet éditeur => dans le forum, et vois si c'est mieux ou pas.

2- identifier le(s) coupable(s) : copie le texte depuis Word vers le forum mais bloc par bloc (genre 5 lignes par 5, ou alors algo dichotomie style tu divises par deux jusqu'à ce que ça passe ou bloque) et vois à partir de quel bloc ça coince, et refais la mm à l'intérieur de bloc ligne par ligne etc... ouais ça prend du temps mais on arrive tjours au bout ^^.


"Well done. Religion has just killed another person"@DrHouse
Avatar de l’utilisateur
peezee
Autiste Raide Dingue
Autiste Raide Dingue
 
Messages: 96340
Enregistré le: 03 Aoû 2003, 03:03
Localisation: MYOB

Re: Possible problème forum

Messagepar Kim Nielsen » 30 Mar 2023, 13:05

peezee, merci !
Je viens de trouver. C'est un espace qui s'est faufilé après une URL d'image qui a foutu le souk.
Ça m'était déjà arrivé, mais sans foutre en l'air l'ensemble du message.
Bref, presque 1h de perdue pour un foutu espace !
Je vais finir par croire que phpbb est misogyne et n'aime pas le foot féminin ! :hehe: comme par zazar ! :mrgreen:

Édith : je viens de virer tous les fichiers word pour les passer en txt.
Avatar de l’utilisateur
Kim Nielsen
Rédacteur
Rédacteur
 
Messages: 9314
Enregistré le: 23 Mai 2003, 19:13
Localisation: St Martin de Crau

Re: Possible problème forum

Messagepar Jester » 30 Mar 2023, 18:27

Même pour les articles, le mieux c'"est de taper le texte brut et mettre en forme au dernier moment avec l'éditeur de Wordpress, car un copié collé de Word, ça passe, mais ça te met un paxon de code en arrière plan, truc de fou.
"Laugh hard. Run fast. Be kind. Doctor... I let you go."
Image
Avatar de l’utilisateur
Jester
Fast Reply
Fast Reply
 
Messages: 85086
Enregistré le: 13 Jan 2002, 04:12
Localisation: Dans mon TARDIS

Re: Possible problème forum

Messagepar Kim Nielsen » 31 Mar 2023, 11:16

Jester, merci pour l'info. Je faisais mes article sous Word. Maintenant je le sais.
Avatar de l’utilisateur
Kim Nielsen
Rédacteur
Rédacteur
 
Messages: 9314
Enregistré le: 23 Mai 2003, 19:13
Localisation: St Martin de Crau


Retourner vers Fonctionnement

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités

cron